Deployment Architecture

How to resolve Server Abort error - Nginx Reverse Proxy (load balancing)

BP9906
Builder

I thought I'd mention that I came across an error and worked with Splunk Support to determine the cause.

I had recently upgraded from Spunk 6.3.x to Splunk 6.4.x and I've been using Nginx as reverse proxy for a long time so that I can load balance traffic between peers of my SHC (search head cluster).

The error was happening when I tried to save a search in the Saved Searches menu via Settings > Saved Searches (old style).

The issue was apparent in Chrome console that I was getting conflicting X-Frame-Options headers. Previously I put in this config and changed it to match Splunk:

OLD:
add_header X-Frame-Options DENY;

NOW:
add_header X-Frame-Options "SAMEORIGIN";

This resolved my issue, in case someone else comes across it. Apparently Splunk implemented X-Frame-Options in 6.4 so thats why this issue was happening. I suppose I could remove the header altogether from Nginx but I thought I'd share what the cause and change was that helped me.

1 Solution

BP9906
Builder

Nginx reconfigured.

View solution in original post

0 Karma

BP9906
Builder

Nginx reconfigured.

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...