Deployment Architecture

Error in Pre-deploy check

Nawab
Communicator

I have 3 new splunk enterprise. 2 are acting as search heads and 1 is acting as deployer.

I have successfully made them as a cluster and can even push user and search configs but when i push app or add-ons from deployer i get below error.

 

Error in pre-deploy check, uri=https://x.x.x.x8089/services/shcluster/captain/kvstore-upgrade/status, status=401, error=No error

even the password is correct for deployer which is also same for both SHs.

What could be the issue here

 

PS: I know splunk recommend to use 3 SH and 1 deployer. I tried it as well but have same issue.

Labels (2)
Tags (1)
0 Karma
1 Solution

Nawab
Communicator

I found the solution. 
It was Pass4symmkey issue, I had some special charaters in my pass4symmkey due to which there was a difference is passwords.

to check use below commands.

splunk btool server list shcluster --debug | grep -i pass4symmkey ( this will give you your password on spunk)

splunk show-decrypted --value 'pass4symmkey' (this will decrypt the key)

 

now verify the pass key it will surely be a missmatch.

View solution in original post

Nawab
Communicator

I found the solution. 
It was Pass4symmkey issue, I had some special charaters in my pass4symmkey due to which there was a difference is passwords.

to check use below commands.

splunk btool server list shcluster --debug | grep -i pass4symmkey ( this will give you your password on spunk)

splunk show-decrypted --value 'pass4symmkey' (this will decrypt the key)

 

now verify the pass key it will surely be a missmatch.

splunkreal
Influencer

Hello, thanks for your help, had similar issue due to splunk init shcluster-config, secret key wasn't correctly encrypted in server.conf apparently, as seen with help of splunk show-decrypted

* If this helps, please upvote or accept solution if it solved *
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...