Dashboards & Visualizations

fetch host

Jasmine
Path Finder

what is the error in the below query which i am using to populate in drop down list

index=aaa(source="/var/log/testd.log") |stats count by host
| eval env=case(match(host, "*10qe*"), "Test",
match(host, "*10qe*"), "QA",
match(host, "*10qe*"), "Prod" )

 

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Jasmine ,

as @marnall said a space is missing between the index value and the source condition.

I suppose that the erro is that the argument of the match function in the eval command is a regex, so you don't need to use asterisk:

index=aaa (source="/var/log/testd.log") 
| stats count by host
| eval env=case(
   match(host, "10qe"), "Test",
   match(host, "10qe"), "QA",
   match(host, "10qe"), "Prod")

Ciao.

Giuseppe

0 Karma

marnall
Motivator

Some potential problems with your query are:

1. index=aaa(source="/var/log/testd.log")
Does not have a space between the index and source filters

2. the match() functions in your eval env=case() part should have valid regexes in the second argument of the match function, as in match(<field>,<regex>). Try this:
| eval env=case(match(host, ".*10qe.*"), "Test",
match(host, ".*10qe.*"), "QA",
match(host, ".*10qe.*"), "Prod" )

ref: https://docs.splunk.com/Documentation/SCS/current/SearchReference/ConditionalFunctions

0 Karma

Jasmine
Path Finder

host is same across all the env. i am facing issue when i bind the same value to drop down list saying "Duplicate values causing conflict". But i need dropdown list with TEST/QA/PROD(label) with same host value. - how can i achieve this?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...