Dashboards & Visualizations

XML error defining view

Builder

I'm receiving the following error when adding a row to my dashboard View:

"Encountered the following error while trying to update: In handler 'views': Not valid XML: Web Serv..."

Here's what I added:

Weblogic message codes in the past 24 hours index=main sourcetype="weblogic" "BEA-\d\d\d\d\d\d)"|top BEA_MSG_NO limit=10000 -25h -1m

As far as I can tell, it looks okay. Am I missing something?

Thanks!

Tags (2)
0 Karma

Builder

Can you post the xml? Normally this happens when you don't have a closing tag on a xml field. I'm curious if the \d is be prased out as a closed field that doesn't exist and causing the error.

If you can't post your xml, if you remove the \d's does the error go away?

Weblogic message codes in the past 24 hours index=main sourcetype="weblogic" "BEA-*)"|top BEA_MSG_NO limit=10000 -25h -1m

if so, then you should create a macro for your search above and use the macro name in place of the search.

0 Karma

Splunk Employee
Splunk Employee

You may have to enclose the string in a set of <[CDATA[...]]> tags, and if you use the code sample button in the editor, it will reformat pasted code so it is literally displayed.

0 Karma

Builder

I can't seem to post the XML on here. It just shows up blank...
I did double-check the closing tags and everything looks okay there. I also tried removing the \d's, but I still have the problem.
I suspect the problem is with the search string (everything else is a copy/paste from a previous row):
sourcetype="weblogic" "BEA-\d\d\d\d\d\d)"|stats count by BEA_MSG_NO

0 Karma