Dashboards & Visualizations

Why is a user getting an error and cannot modify a dashboard they created?

KooroshFooladba
Explorer

Hi, one of the users cannot modify a dashboard that he has created last week. the error says:

Encountered the following error while trying to update: In handler 'views':Failed to lock /DeptGroup/GPFSmounts/splunksearch/etc/apps/sentinel.txt with code 1, possible reason: success

Thank

Tags (2)
0 Karma
1 Solution

bohrasaurabh
Communicator

Looks like there is search head pooling. shutdown all the sh and then delete sentinel.txt and sentinel.txt.lock. Then start sh's

View solution in original post

bohrasaurabh
Communicator

Looks like there is search head pooling. shutdown all the sh and then delete sentinel.txt and sentinel.txt.lock. Then start sh's

KooroshFooladba
Explorer

Problem solved with the instruction.

Thanks

0 Karma

DerekKing
Path Finder

Maybe the view has a typo somewhere in it.

If you navigate to SPLUNK_HOME/bin and run ./splunk btool check

That may point you in the right direction.

Derek

0 Karma

KooroshFooladba
Explorer

Thanks for the hint, unfortunately it didn't help. nothing was returned after running the check tool.

0 Karma

pawan_acharya
New Member

I am also facing the same issue. Any idea how your issue was resolved?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...