Dashboards & Visualizations

Token

Stives
Explorer

Dear Sir, I would like to set a token in order to be able modify -1h treshold.

| tstats latest(_time) as latest where index=* earliest=-24h by host
| eval recent = if(latest > relative_time(now(),"-1h"),1,0), realLatest = strftime(latest,"%c")
| eval data=case(recent=="0","No Data",recent=="1","OK")
| table host,realLatest,data

My earliest -24h token works fine, but I would like to set token alo for "-1h" relative time in order to be able modify treshold. Can you help ?

Thank you in advance.

regards,

Stives

Labels (1)
0 Karma

Stives
Explorer

Resolved, thaks

0 Karma

niketn
Legend

@Stives Request you to post what you tried which fixed the issue. Accept the answer to mark the question as answered.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...