Dashboards & Visualizations

PARSER: Applying intentions failed 'unicode' object has no attribute 'get'

Path Finder

(NOTE - I have read other similar posts and solutions have not helped)

I have a created a dashboard with 2 text boxes for a search. The default value if nothing enetered is "*".

This worked well until i needed to add a radio button to the search options and i was forced to convert to advanced XML.

Now i have converted all works well if i leacve text boxes empty and the search uses the *, but if anything entered into text boxes i get the error below:

PARSER: Applying intentions failed 'unicode' object has no attribute 'get'

http://splunk-base.splunk.com/answers/3606/unicode-object-has-no-attribute-get#3665).:
This one states to add the line

<param name="value"></param>

This does not fix issue. It also says to change the order round- this does nto seem to work either! my code:

 <module name="ExtendedFieldSearch">
      <param name="replacementMap">
        <param name="arg">
          <param name="Group"/>
              </param>
          </param>
      <param name="field">Enter ’Group' name</param>
      <param name="intention">
        <param name="name">stringreplace</param>
        <param name="arg">
          <param name="Group">
            <param name="default">*</param>
            <param name="fillOnEmpty">True</param>
          </param>
        </param>
      </param>

      <module name="ExtendedFieldSearch">
        <param name="replacementMap">
          <param name="arg">
            <param name="UserAddedRemoved"/>
                </param>
        </param>
        <param name="field">Enter 'Username'</param>
        <param name="intention">
          <param name="name">stringreplace</param>
          <param name="arg">
            <param name="UserAddedRemoved">
              <param name="default">*</param>
              <param name="fillOnEmpty">True</param>
            </param>
          </param>
        </param>

let me know if you need more?

Please do not just point me to another post as none of them clearly identify what needs changing

0 Karma
1 Solution

Builder

The question you linked has the answer. In the replacementMap sections, where your XML says


<param name="UserAddedRemoved"/>

you need to change it to


<param name="UserAddedRemoved">
<param name="value"></param>
</param>

It's not just adding the value param line; you have to remove the trailing / from the name=UserAddedRemoved line to ensure the value definition is part of the correct parent block. Same goes for the Group replacement map section. I copied your XML into a test view and verified that it worked with these changes. (It also wanted me to add a layoutPanel parameter to the ExtendedFieldSearch module definition, but that's a quick fix.)

View solution in original post

0 Karma

Builder

The question you linked has the answer. In the replacementMap sections, where your XML says


<param name="UserAddedRemoved"/>

you need to change it to


<param name="UserAddedRemoved">
<param name="value"></param>
</param>

It's not just adding the value param line; you have to remove the trailing / from the name=UserAddedRemoved line to ensure the value definition is part of the correct parent block. Same goes for the Group replacement map section. I copied your XML into a test view and verified that it worked with these changes. (It also wanted me to add a layoutPanel parameter to the ExtendedFieldSearch module definition, but that's a quick fix.)

View solution in original post

0 Karma