Dashboards & Visualizations

Line chart drilldown question.

aarzhang
New Member

query:
index=app sourcetype=XXXX eventName=xxx | bucket _time span=1m | stats count as total, count(eval(success="false")) as failureCount by _time, eventName | eval successRate=100*(total-failureCount)/total | xyseries _time eventName successRate

I build a line chart like the image.
Now , I want to add drilldown function, how can I get the eventName when I click down.
I have try $click.value$ , $row.field$, $click.value2$, but failed.

alt text

Tags (1)
0 Karma
1 Solution

somesoni2
Revered Legend

Since the value that want to capture is the label/field name for y-axis, try using $click.name2$.

See more details here. Open the link and search for "chart (event tokens)"

http://docs.splunk.com/Documentation/Splunk/6.2.5/Viz/PanelreferenceforSimplifiedXML#Drilldown_eleme...

View solution in original post

0 Karma

somesoni2
Revered Legend

Since the value that want to capture is the label/field name for y-axis, try using $click.name2$.

See more details here. Open the link and search for "chart (event tokens)"

http://docs.splunk.com/Documentation/Splunk/6.2.5/Viz/PanelreferenceforSimplifiedXML#Drilldown_eleme...

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...