Dashboards & Visualizations

How to remove null values from chart

stefan1988
Path Finder

Hello,

How could I exclude rows where one out of two domains is showing a null value?

My search is:
| chart avg(time_taken) over uri by domainname

For example I get the following result

Uri | DomainA | DomainB

uri1 1.1 1.2
uri2 2.1
uri3 1.8 0.4

uri2 is having one null value. I would like to exclude the row for uri2.

Many thanks.

Tags (1)
0 Karma
1 Solution

masonmorales
Influencer

Try

... | eventstats dc(domainname) as doman_count | search domain_count>=2| chart avg(time_taken) over uri by domainname

View solution in original post

masonmorales
Influencer

Try

... | eventstats dc(domainname) as doman_count | search domain_count>=2| chart avg(time_taken) over uri by domainname

stefan1988
Path Finder

alt text

I've tried with eventstats, but I still see rows with null values.

0 Karma

starcher
Influencer

if you simply want to drop rows with either column having a null. you could do something like

... | where isnotnull(DomainA) AND isnotnull(DomainB)
0 Karma

stefan1988
Path Finder

Both DomainA and DomainB are values (and not fields). Found the answer, it's possible with the following search:

index=in_oracle_soa sourcetype=oracle_soa_server_accesslog NOT "#" | rex "(?<c_ip>[^\t]+)\t(?<datum>[^\t]+)\t(?<tijd>[^\t]+)\t(?<method>[^\t]+)\t(?<uri>[^\t]+)\t(?<status_code>[^\t]+)\t(?<bytes>[^\t]+)\t(?<time_taken>[^\t]+)" |stats avg(time_taken) as "avg" by uri domainname |eventstats dc(domainname) as uniqvalues by uri | where uniqvalues>1 |xyseries uri,domainname,avg
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...