Dashboards & Visualizations

How to hide Checkboxes from dashboard

sagar1992
Explorer

Hi Team,

I have one parent checkbox (All reports), after clicking on it, it sets and unsets the child token.

As I have many panels, I would like to hide child checkboxes. Is there any way to do this change. JAVASCRIPT is not in favor, normal XML configurations will do.

Screenshot below:alt text

@niketnilay - any help appreciated 🙂 Thank You.

0 Karma
1 Solution

vnravikumar
Champion

Hi

Try this

<form>
  <label>checkboxall</label>
  <fieldset submitButton="false">
    <input type="checkbox" token="field1" searchWhenChanged="true">
      <label></label>
      <choice value="all">All Reports</choice>
      <change>
        <condition value="all">
          <set token="form.field2">monthly</set>
          <set token="form.field3">daily</set>
          <set token="form.field4">table</set>
        </condition>
        <condition>
          <unset token="form.field2"></unset>
          <unset token="form.field3"></unset>
          <unset token="form.field4"></unset>
        </condition>
      </change>
      <delimiter> </delimiter>
    </input>
    <input type="checkbox" token="field2" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="monthly">Monthly Report</choice>
      <change>
        <condition value="monthly">
          <set token="showpanel1">true</set>
        </condition>
        <condition>
          <unset token="showpanel1"></unset>
        </condition>
      </change>
    </input>
    <input type="checkbox" token="field3" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="daily">Daily Report</choice>
      <change>
        <condition value="daily">
          <set token="showpanel2">true</set>
        </condition>
        <condition>
          <unset token="showpanel2"></unset>
        </condition>
      </change>
    </input>
    <input type="checkbox" token="field4" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="table">Monthly Report(Table Format)</choice>
      <change>
        <condition value="table">
          <set token="showpanel3">true</set>
        </condition>
        <condition>
          <unset token="showpanel3"></unset>
        </condition>
      </change>
    </input>
  </fieldset>
  <row>
    <panel depends="$showpanel1$">
      <table>
        <title>Monthly Report</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
  <row>
    <panel depends="$showpanel2$">
      <table>
        <title>Daily Report</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
  <row>
    <panel depends="$showpanel3$">
      <table>
        <title>Monthly Report(Table Format)</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
</form>

View solution in original post

0 Karma

vnravikumar
Champion

Hi

Try this

<form>
  <label>checkboxall</label>
  <fieldset submitButton="false">
    <input type="checkbox" token="field1" searchWhenChanged="true">
      <label></label>
      <choice value="all">All Reports</choice>
      <change>
        <condition value="all">
          <set token="form.field2">monthly</set>
          <set token="form.field3">daily</set>
          <set token="form.field4">table</set>
        </condition>
        <condition>
          <unset token="form.field2"></unset>
          <unset token="form.field3"></unset>
          <unset token="form.field4"></unset>
        </condition>
      </change>
      <delimiter> </delimiter>
    </input>
    <input type="checkbox" token="field2" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="monthly">Monthly Report</choice>
      <change>
        <condition value="monthly">
          <set token="showpanel1">true</set>
        </condition>
        <condition>
          <unset token="showpanel1"></unset>
        </condition>
      </change>
    </input>
    <input type="checkbox" token="field3" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="daily">Daily Report</choice>
      <change>
        <condition value="daily">
          <set token="showpanel2">true</set>
        </condition>
        <condition>
          <unset token="showpanel2"></unset>
        </condition>
      </change>
    </input>
    <input type="checkbox" token="field4" searchWhenChanged="true" rejects="$field1$">
      <label></label>
      <choice value="table">Monthly Report(Table Format)</choice>
      <change>
        <condition value="table">
          <set token="showpanel3">true</set>
        </condition>
        <condition>
          <unset token="showpanel3"></unset>
        </condition>
      </change>
    </input>
  </fieldset>
  <row>
    <panel depends="$showpanel1$">
      <table>
        <title>Monthly Report</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
  <row>
    <panel depends="$showpanel2$">
      <table>
        <title>Daily Report</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
  <row>
    <panel depends="$showpanel3$">
      <table>
        <title>Monthly Report(Table Format)</title>
        <search>
          <query>index="_internal" |stats count by host</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="drilldown">none</option>
      </table>
    </panel>
  </row>
</form>
0 Karma

sagar1992
Explorer

@vnravikumar Thanks it worked!!

rejects="$field1$"

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...