Dashboards & Visualizations

How to create a simple dashboard showing AD admin account lockout events?

blmclaws
Engager

I am new to Splunk and have been tasked with creating a dashboard that will show detail about account lockout events. Specifically when an administrator account has been locked out, why and on what device. I don't need anything fancy right now just something that works and I can add more to it later. I have evaluated other answers to similar questions and can't seem to get any of them to work but they also seem to be more complex and I can't decipher them yet because of my limited splunk knowledge.

0 Karma
1 Solution

amitm05
Builder

Hi bimclaws

Assuming you are working on windows security logs for this.
Running the following SPL will give you the statics you stated above:
index="YourIndex" sourcetype="Your Windows sourcetype" EventCode=4740 |stats count values(user) as user values(signature) as action by src | rename src as Source

You might need to check for any field name changes or other tweaks that you may require.
After running the SPL, you can save it as a dashboard panel. At Dashboard panel you can further have the options of working with the visulaizations.

Hope this helps

View solution in original post

amitm05
Builder

Hi bimclaws

Assuming you are working on windows security logs for this.
Running the following SPL will give you the statics you stated above:
index="YourIndex" sourcetype="Your Windows sourcetype" EventCode=4740 |stats count values(user) as user values(signature) as action by src | rename src as Source

You might need to check for any field name changes or other tweaks that you may require.
After running the SPL, you can save it as a dashboard panel. At Dashboard panel you can further have the options of working with the visulaizations.

Hope this helps

blmclaws
Engager

This is what I needed and it's a great start! Thanks.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...