Dashboards & Visualizations

Date Picker in Simple XML

lahariveerlapat
Explorer

My requirement is to pick a single date rather than selecting the Date Range in Time Range Picker Or Date Range to select as default in Time Range Picker
Any suggestions plz.....

0 Karma

sloshburch
Ultra Champion

If you haven't seen it, http://docs.splunk.com/Documentation/Splunk/latest/Admin/Timesconf might be of use to you.

On the other hand, you can create an input that defines a token you can use as the values for earliest and latest in the search string.

If you provide more detail or an example of what you're trying to do, we can provide a more effectives solution/recommendation.

0 Karma

mnatkin_splunk
Splunk Employee
Splunk Employee

The way I handled this recently was to forego the time picker and use a multi-select in concert with the automagic "date" field. Note: I've limited the date picker here to the last 15 days, so as not to overtax the SH. Adjust the parameter to meet your needs.

<input type="multiselect" token="DATE_tok" searchWhenChanged="true">
      <label>Date</label>
      <choice value="*">Any</choice>
      <prefix>(</prefix>
      <suffix>)</suffix>
      <valuePrefix>date="</valuePrefix>
      <valueSuffix>"</valueSuffix>
      <delimiter> OR </delimiter>
      <fieldForLabel>date</fieldForLabel>
      <fieldForValue>date</fieldForValue>
      <search>
        <query>sourcetype="SplunkNinjaDataSource" | stats count by date</query>
       <earliest>-15d@h</earliest>
       <latest>now</latest>
      </search>
    </input>

Just add the token $DATE_tok$ into your search, and you're off to the races.

HTH

intelsubham
Explorer

If you select same date in both textboxes , it is automatically equivalent to 1 day. i.e. if you are selecting 05/27/2015 in both text boxes, it actually means 05/27/2015 (00:00:00) to 05/27/2015 (24:00:00).
As of now, I think there are not any available parameters under timerangepicker module which can help us achieving this.

0 Karma

splunk_mkhan
Explorer

I am looking for same.
Want to create a calendar date picker field in setup.xml.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...