Dashboards & Visualizations

Data Utilization Dashboard

ravikanthbadugu
New Member

Hello All,

How we can get the stats of Internet Data Utilization by multiple Users for Different time periods.

0 Karma

HiroshiSatoh
Champion

What do you specifically want to do?

For example, is this App helpful?
It can be used if the log supports the data model.
https://splunkbase.splunk.com/app/2699/

0 Karma

ravikanthbadugu
New Member

index=xyz Source=abc earliest=@d+09h latest=now |stats latest(PacketsReceived) as PacketsReceived,latest(PacketsSent) as PacketsSent by LoggedInUser | convert num(PacketsReceived) as PacketsReceived,num(PacketsSent) as PacketsSent| eval TotalB=PacketsReceived+PacketsSent |search LoggedInUser!=root|search LoggedInUser!=admin

using this query we want output for 3 different timelines. , one is fromyesterday 9:30 am to today 6:30 Pm and today 11:30 am to 6:30 pm and today 9:30 am to 11:30 am

0 Karma

cmerriman
Super Champion

Are timezones an issue for this search? You could just create an eval statement that says if _time is between certain hours to mark it as one time period, and so on.

0 Karma

ravikanthbadugu
New Member

We have users working remotely I want to know how much internet data each user is consuming for doing their work for different time periods.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...