All Apps and Add-ons

log is going to _internal index

shashidharh
Explorer

Hi,

Logs are going to _internal index instead of customized index.

host = xxxx
index = _internal
source = C:\Program Files\SplunkUniversalForwarder\var\log\splunk\splunkd.log
sourcetype = splunkd

inputs.conf and props.conf are set properly in deployment server.Also verified in the SplunkForwarder "Windows"  server.  Still getting above one , not going to customized index.

What could be the reason ?

Labels (3)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

The reason is simple: that is where Splunk is told to put the data.  It's also the default setting so no real surprise.  To find out which config file is specifying the settings, run btool on the forwarder.

\Program Files\Splunk\bin\splunk.exe btool --debug inputs list 

Then you'll know which file to modify to have the data go to the desired index.

Be aware that sending data to a custom index rather than _internal may have license implications and may break some dashboards.

---
If this reply helps you, an upvote would be appreciated.
0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>