All Apps and Add-ons

Writing a Splunk Query - Unique Count of Initial Access Key Usage from Cloudtrail

tosilesi19
New Member

I have a use case to write a splunk query to display in a line or area chart the unique and initial AWS access key usage by IAM users in our org trending for the past year. Management want to be able to visually show increased cloud adoption numbers over time. Any ideas on how to display this? I feel like I'm almost there with stats but not quite.

index=blah sourcetype=blah user_type=SAMLuser | stats earliest(eventTime) by userIdentity.userName

This almost gets me there, but it won't depict the stats in a pretty line chart.

Thanks!

0 Karma

to4kawa
Ultra Champion

If eventTime is epoch time, how about this?

index=blah sourcetype=blah user_type=SAMLuser 
| stats earliest(eventTime) as _time by userIdentity.userName
| timechart count by userIdentity.userName
0 Karma

tosilesi19
New Member

this gets me closer! but the userIdentity.userName values are all just flat on the x-axis. I need them to display clearly based on the date they were first used.

0 Karma

to4kawa
Ultra Champion

what's y-axis?
a line or area chart's y-axis is number,you know.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...