All Apps and Add-ons

Why is the website monitoring app giving the error "Exception generated when attempting to get the proxy configuration"

jacobpevans
Motivator

@LukeMurphey

According to the issue at the URL below, this problem was resolved in 2.7.5, but I am on version 2.9.2.

https://github.com/LukeMurphey/splunk-website-monitoring/issues/31

Here's the error:

2020-03-11 12:46:05,880 ERROR Exception generated when attempting to get the proxy configuration stanza=web_ping://[web input name], see url=http://lukemurphey.net/projects/splunk-website-monitoring/wiki/Troubleshooting
Traceback (most recent call last):
  File "D:\Program Files\Splunk\etc\apps\website_monitoring\bin\web_ping.py", line 941, in run_ping
    self.get_proxy_config(input_config.session_key, conf_stanza)
  File "D:\Program Files\Splunk\etc\apps\website_monitoring\bin\modular_input.zip\modular_input\shortcuts.py", line 31, in wrapper
    return function(*args, **kwargs)
  File "D:\Program Files\Splunk\etc\apps\website_monitoring\bin\web_ping.py", line 799, in get_proxy_config
    website_monitoring_config = self.get_app_config(session_key, stanza)
  File "D:\Program Files\Splunk\etc\apps\website_monitoring\bin\modular_input.zip\modular_input\shortcuts.py", line 31, in wrapper
    return function(*args, **kwargs)
  File "D:\Program Files\Splunk\etc\apps\website_monitoring\bin\web_ping.py", line 735, in get_app_config
    raise Exception("Could not get the website_monitoring configuration")
Exception: Could not get the website_monitoring configuration

The steps I performed to achieve this:
- Install website monitor version 2.7.6
- Add a website input
- I believe it was broken here, but I did not verify this
- Upgrade to the latest website monitor (2.9.2)

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.
0 Karma
1 Solution

jacobpevans
Motivator

It's hidden, but at the bottom of Luke's troubleshooting is the answer (http://lukemurphey.net/projects/splunk-website-monitoring/wiki/Troubleshooting).

Specifically,

Some of my inputs are returning a 403 error even though I haven't told them to use authentication.
This is likely because you have a proxy server configured but you input is unable to authenticate with the proxy. Oftentimes, this happens because there is a global HTTP proxy defined using using environment variables (often in $SPLUNK_HOME/etc/splunk-launch.conf).

To get around this, define a value for the proxy_ignore setting in website_monitoring.conf. You can also set this using the setup page for the Website Monitoring app. Set the value of the "Server Ignore List" to "*", like this:

All I did was set "Server Ignore List" to * via the GUI. Problem solved. My website_monitoring.conf looks like this:

[default]
proxy_type = http
thread_limit = 20
proxy_ignore = *

I would think this could be handled in the default website_monitoring.conf, but I'll leave that to the expert @LukeMurphey . Thanks for a great app! I just wanted to get this answer up since I do not see it anywhere else besides your troubleshooting wiki.

Cheers,
Jacob

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.

View solution in original post

0 Karma

jacobpevans
Motivator

It's hidden, but at the bottom of Luke's troubleshooting is the answer (http://lukemurphey.net/projects/splunk-website-monitoring/wiki/Troubleshooting).

Specifically,

Some of my inputs are returning a 403 error even though I haven't told them to use authentication.
This is likely because you have a proxy server configured but you input is unable to authenticate with the proxy. Oftentimes, this happens because there is a global HTTP proxy defined using using environment variables (often in $SPLUNK_HOME/etc/splunk-launch.conf).

To get around this, define a value for the proxy_ignore setting in website_monitoring.conf. You can also set this using the setup page for the Website Monitoring app. Set the value of the "Server Ignore List" to "*", like this:

All I did was set "Server Ignore List" to * via the GUI. Problem solved. My website_monitoring.conf looks like this:

[default]
proxy_type = http
thread_limit = 20
proxy_ignore = *

I would think this could be handled in the default website_monitoring.conf, but I'll leave that to the expert @LukeMurphey . Thanks for a great app! I just wanted to get this answer up since I do not see it anywhere else besides your troubleshooting wiki.

Cheers,
Jacob

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.

View solution in original post

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!