All Apps and Add-ons

Why is Perfmon Memory not showing up in Windows Server 2008 R2?

anzianojackson6
Explorer

I've installed the 6.3.4 forwarder on a Windows 2008 r2. It's got the Splunk Add-on for Microsoft Windows and perfmon enabled, but no perfmon memory is coming across. I'm thinking it's an OS problem. It is enabled and the forwarder has been restarted several times. It's grabbing Perfmon: PhysicalDisk/CPU/Network, etc, but no Memory.

inputs.conf

## Memory
[perfmon://Memory]
counters = *
disabled = 0
interval = 60
object = Memory
0 Karma

danielsofoulis
Path Finder

I'm having the same issue.

0 Karma

sylbaea
Communicator

Here is what I use in my environment:

[perfmon://Memory]
useEnglishOnly=true
showZeroValue = 1
instances = *
object = Memory
counters = % Committed Bytes In Use; Available MBytes; Pages Input/sec;Free System Page Table Entries;Pages/sec
interval = 60
disabled = 0

Also, if you think it is an OS problem... Have you simply try to use perfmon directly to confirm the related counters still work as expected ?

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...