All Apps and Add-ons

When I open an add-on in Splunk Web, why am I getting redirected to a different add-on page?

ecaepp
Explorer

Morning,

I am having an issue in Splunk web console.

Every time I try to open an Add-on, I get redirected to a different Add-ons page, most notably is *nix Add-on.

I can disable the Add-on to eventually get to the one I am trying to open, but this is really inconvenient.

Has anyone else experienced or have a solution to this issue?

alt text

0 Karma
1 Solution

rpille_splunk
Splunk Employee
Splunk Employee

The add-ons that you are trying to access may not have any views (dashboards, custom configuration screens, etc) in Splunk Web. If you make an add-on "visible" in Splunk Web, but the add-on doesn't have any views to show, then this can happen.

In the screenshot above, it looks like you are trying to get to the Splunk Add-on for Nessus. The Splunk Add-on for Nessus doesn't have any views. You can set up this add-on by going to Apps > Manage Apps and then clicking on Set up in the row for Splunk Add-on for Nessus. You can get to the inputs by going to Settings > Data inputs, then clicking on Splunk Add-on for Nessus. No custom views are required for either action.

To turn off visibility for an add-on, go to Apps > Manage Apps, then click on Edit Properties in the row for that add-on. Change Visibility from Yes to No.

View solution in original post

rpille_splunk
Splunk Employee
Splunk Employee

The add-ons that you are trying to access may not have any views (dashboards, custom configuration screens, etc) in Splunk Web. If you make an add-on "visible" in Splunk Web, but the add-on doesn't have any views to show, then this can happen.

In the screenshot above, it looks like you are trying to get to the Splunk Add-on for Nessus. The Splunk Add-on for Nessus doesn't have any views. You can set up this add-on by going to Apps > Manage Apps and then clicking on Set up in the row for Splunk Add-on for Nessus. You can get to the inputs by going to Settings > Data inputs, then clicking on Splunk Add-on for Nessus. No custom views are required for either action.

To turn off visibility for an add-on, go to Apps > Manage Apps, then click on Edit Properties in the row for that add-on. Change Visibility from Yes to No.

View solution in original post

ecaepp
Explorer

Thank you!

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.