All Apps and Add-ons

WebTools AddOn: Curl '401 - Forbidden' - ntlm not implemented?


Hey there,

we've worked out the reason why our attempts to GET some data (in this case, from a Sharepoint Server) using your awesome addon always gave us a 401.
Using the vanilla curl version of the command from $bash on our server, we'd also get a 401 when not providing the --ntlm option, but getting a valid response when adding it:

curl --ntlm -u DOMAIN/USER:PASSWORD "'GUID-OF-OUR-LIST')/items?$select='ID,FIELD1,FIELD2,FIELD3'" -H 'accept: application/json'

Is there a way to have your addon provide this option?

Otherwise we'd be stuck with taking the long route, i.e. using a script that'd create a file which we'd then index to process it from there...

Thanks and Best Regards,

0 Karma


Does anyone have an idea or has tried this as well? Any feedback would be much appreciated.

Best regards

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!


Or Learn More in Our Blog >>