All Apps and Add-ons

Web Tools Add-On | Restarting a Forwarder

cboillot
Contributor

When using cURL, I can run
curl -k -u admin:changeme https://localhost:8089/services/server/control/restart -X POST
With no issues, but when I bring this into Splunk using
| curl method=post uri=https://localhost:8089/services/server/control/restart user=admin pass=changeme
I get the following error
<?xml version="1.0" encoding="UTF-8"?> <response> <messages> <msg type="ERROR">Invalid request, restart requires POST (handler: server-control, action:restart, eai action: list).</msg> </messages> </response>
Any thoughts or ideas how I can get this to work?

0 Karma

jkat54
SplunkTrust
SplunkTrust

Please download the latest release of the app. This bug has been resolved.

0 Karma

jkat54
SplunkTrust
SplunkTrust

There’s a bug in the latest version that breaks non-splunk auth connections. So I’d recommend downgrading for now until I can release a bug fix.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...