All Apps and Add-ons

Splunk Stream not working

windsurfer30
Explorer

This is driving me nuts, I'm trying to setup splunk stream for netflow.

I've uploaded the app and at the end of the upload it gives me an error: Error connecting to /servicse/apps/local: timed out

Nonetheless one of the messages prompts me to restart Splunk so I do. And I see the Splunk Stream app but when I go to it, it comes up blank. The logs say
2019-11-06 09:25:36 ERROR 140167464486656 stream.CaptureServer - Unable to ping server (9c5d65be-af86-4b47-b0e3-cb31198ab475): /en-us/custom/splunk_app_stream/ping/ status=404

Why would I be getting 404 errors on a default install?
the splunk system local web.conf has the httpport set 8000

if I wget the URL on localhost:8000 I get
Connecting to localhost (localhost)|127.0.0.1|:8000... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-11-06 09:31:39 ERROR 404: Not Found.

please help?

0 Karma
1 Solution

windsurfer30
Explorer

Nevermind. I was trying to run it on Splunk 8.0 switched to splunk 7.3.2 and working now

View solution in original post

windsurfer30
Explorer

Nevermind. I was trying to run it on Splunk 8.0 switched to splunk 7.3.2 and working now

View solution in original post

windsurfer30
Explorer

Forgot to mention that I also did run the ./set_permissions.sh script as indicated in the instructions

0 Karma

windsurfer30
Explorer

And in the GUI if I click and try and open splunk_app_stream it goes to
... en-US/app/splunk_app_stream/info_overview

but the whole page is blank

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!