All Apps and Add-ons

Splunk/Salesforce Integration | Disabling SSL certification verification

arunwip
New Member

Hi Experts,

Need your quick suggestion/support.

Trying to make an integration between Splunk with Salesforce using Splunk_TA_salesforce.
Getting below SSL error.

2022-10-06 09:24:35,525 ERROR pid=22321 tid=MainThread file=task.py:_send_request:475 | [stanza_name=monitoring__c] Error occurred in request url=https://company-business--preprod01.sandbox.salesforce.com/services/data/v54.0/query?q=SELECT%20Crea... method=GET reason=HTTP Error HTTPSConnectionPool(host='company-business--preprod01.sandbox.my.salesforce.com', port=443): Max retries exceeded with url: /services/data/v54.0/query?q (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1106)')))

Have placed a certificate pem file in $SPLUNK_HOME/etc/auth/certs/ and defined this path in splunk_ta_salesforce_settings.conf as ca_certs_path = /opt/splunk/etc/auth/certs/cert_chain.pem

But still we get an SSL error, how to disable SSL certificate verifification in the Add-On 'Splunk_TA_salesforce'? Please suggest.

Thanks

0 Karma
Get Updates on the Splunk Community!

Platform Highlights | November 2022 Newsletter

 November 2022 Skill Up on Splunk with our New Builder Tech Talk SeriesCan you build it? Yes you can! *play ...

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...

Five Subtly Different Ways of Adding Manual Instrumentation in Java

You can find the code of this example on GitHub here. Please feel free to star the repository to keep in ...