All Apps and Add-ons

Splunk DB connect is not working for DB2 database


Splunk DB connect is not working for DB2 database.
Installed drivers for DB2 :

Getting license error : [ibm][db2][jcc][10333][11649] No license was found. An appropriate license file db2jcc_license_*.jar must be provided in the CLASSPATH setting.

I tried to update classpath for license file but then Splunk restart , nothing is working, please help...

export CLASSPATH="$SPLUNK_HOME/etc/apps/splunk_app_db_connect/drivers/db2jcc-libs/db2jcc_license_cu.jar"

Tried for another license file as well but again error is same


Per my research, the db2jcc.jar driver is now deprecated. After version 3.72, which is delivered with DB2 Version 11.1 for Linux, UNIX, and Windows Mod 1 Fix Pack 1, db2jcc.jar will include no new features. However, fixes will continue to be delivered.

check this link ->

In additional I found this answer where you can deploy in your environment to test if this issue can be fixed.

further information ->

0 Karma


Anyone , any idea over this error for DB2 database.

0 Karma


Did you update permissions/ownership of the jar files you uploaded? If you're running as the splunk user, ensure that user can read them.

An upvote would be appreciated and Accept Solution if it helps!
0 Karma
Get Updates on the Splunk Community!

Improve Your Security Posture

Watch NowImprove Your Security PostureCustomers are at the center of everything we do at Splunk and security ...

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...