All Apps and Add-ons

Splunk DB Connect: How to resolve "JRE Status: Unsupported JRE detected"?

Amohlmann
Communicator

I have just installed Splunk DB Connect on a fresh install of Splunk.
When I go to set it up, it says:

JRE Status: Unsupported JRE detected
Using Oracle Corporation JRE version 1.8, OpenJDK 64-Bit Server VM
Need Oracle Corporation JRE version 1.8

Originally I had JRE version 1.7, so I removed 1.7 and installed 1.8. I have run all the updates I can so it is running on the latest update of v 1.8.
If I go java -version I get the following:

openjdk version "1.8.0_101"
OpenJDK Runtime Environment (build 1.8.0_101-b13)
OpenJDK 64-Bit Server VM (build 25.101-b13, mixed mode)

Is it the OpenJDK 64-Bit Server VM that is the issue? Do I have to remove this?

I have tried a few other things since originally posting the question, but still cannot for the life of me get it to work.

So, I think my problem is actually I only have OpenJDK.
I have installed the correct JRE from Oracle (got from here: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html)

But It will not let me set the JRE Installation Path in the General Settings of DBX.

1 Solution

Amohlmann
Communicator

I found the issue. I did not have to delete or remove anything. The thing was that I needed to install the Oracle version of JRE (got from here http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

You need to install this in the same directory where the other java stuff is stored. For me I needed to make sure I threw the installation in /usr/lib/jvm

Then I had to change the JRE Installation Path to:
/usr/lib/jvm/jre1.8.0_101

JRE Status is now up

View solution in original post

timpedlar
Engager

DB Connect 3.1.4 now supports OpenJDK 8.

https://docs.splunk.com/Documentation/DBX/latest/ReleaseNotes/Releasenotes

Update to 3.1.4 and your error will go away!

0 Karma

weiwang1
Engager

Not necessarily: DBConnect 3.1.4 doesn't recognize OpenJDK 1.8 on Ubuntu server

I have the exact same issue.

0 Karma

mahsaalaeifar
Explorer

I installed jdk-8u181-linux-x64.rpm instead of the previous jre 8
then change the java home to point to new JDK (/usr/java/jdk1.8.0_181-amd64) the issue gone !

Amohlmann
Communicator

I found the issue. I did not have to delete or remove anything. The thing was that I needed to install the Oracle version of JRE (got from here http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

You need to install this in the same directory where the other java stuff is stored. For me I needed to make sure I threw the installation in /usr/lib/jvm

Then I had to change the JRE Installation Path to:
/usr/lib/jvm/jre1.8.0_101

JRE Status is now up

richgalloway
SplunkTrust
SplunkTrust

DB Connect is very fussy about the JRE it uses. Removing the OpenJDK should fix it.

---
If this reply helps you, Karma would be appreciated.

Amohlmann
Communicator

So, I think my problem is actually I only have OpenJDK.
I have installed the correct JRE from Oracle (got from here: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html)

But It will not let me set the JRE Installation Path in the General Settings of DBX.

0 Karma

jamin358
Explorer

This should be the accepted answer

Get Updates on the Splunk Community!

How I Instrumented a Rust Application Without Knowing Rust

As a technical writer, I often have to edit or create code snippets for Splunk's distributions of ...

Splunk Community Platform Survey

Hey Splunk Community, Starting today, the community platform may prompt you to participate in a survey. The ...

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...