All Apps and Add-ons

Splunk DB Connect 3: How to resolve "Error in 'dbxquery' command: Could not find file: 'java.path'"

bjmclean
Explorer

I am getting the following error whenever I try to use SQL explorer or create an input in DB Connect 3:

Error in 'dbxquery' command: Could not
find file: 'java.path'

I have another server where I'm getting a similar, but slightly different error:

Error in 'dbxquery' command: Could not
find file: 'custom.java.path'

The JRE home settings populated automatically in the DB Connect settings, and I've tried switching between the JRE and JDK home directories with no success. What would cause this type of error?

Thank you!

1 Solution

rm250
Explorer

Version compatibility was the issue. After upgrading to Splunk 6.6, this issue was solved.

View solution in original post

koushikbhushan
New Member

Changing the path to JDK installation path solved my error. It was poiting to JRE installtion directory before. If problem is not resolved, try to change the jdk version.

0 Karma

rm250
Explorer

Version compatibility was the issue. After upgrading to Splunk 6.6, this issue was solved.

bush123
New Member

I have the same problem splunk note me:Error in 'dbxquery' command: Could not find file: 'customized.java.path'

0 Karma

rm250
Explorer

I have the same issue. I dont have bin on the path.
java version is 1.8.0_121
JRE Installation path(JAVA_HOME): C:\Program Files\Java\jdk1.8.0_121

0 Karma

vicvaughan
Explorer

I am having the same issue. using java 1.8.0_101

Any new answers?

0 Karma

bush123
New Member

I think I solved this problem, before I use the splunk6.3, has been prompted to find java.path, then I upgraded the splunk to 6.6, went to mysql official website to download the latest jdbc, and then download the compressed package Decompression to the driver, just fine

0 Karma

gfreitas
Builder

What java.path are you using? What path is your java bin?
When you run the command "java version", what it shows?
You must be using JDK only on version 8 at least update 121 or later

0 Karma

gfreitas
Builder

Could you try add just: C:\Program Files\Java as the path?

0 Karma

rm250
Explorer

Hi @gfreitas That didn't work.
I changed the path to C:\program files\Java
I got error when I click "save" button on the general settings.

c:\program files\splunk\python-2.7\lib\subprocess.py\ , line 958, in_execute_child startup info WindowsError [Error 2] The sytem cannot find the file specified

0 Karma

rm250
Explorer

Hi, anyone has any suggestion on how to resolve this.

0 Karma
Get Updates on the Splunk Community!

Your Guide to SPL2 at .conf24!

So, you’re headed to .conf24? You’re in for a good time. Las Vegas weather is just *chef’s kiss* beautiful in ...

Get ready to show some Splunk Certification swagger at .conf24!

Dive into the deep end of data by earning a Splunk Certification at .conf24. We're enticing you again this ...

Built-in Service Level Objectives Management to Bridge the Gap Between Service & ...

Now On-Demand Join us to learn more about how you can leverage Service Level Objectives (SLOs) and the new ...