All Apps and Add-ons

Splunk App for Web Analytics: Why does the Generate Page Lookup fail and "http_request" field does not appear to exist?

willisiw
Explorer

I have green checks on everything except page lookups. I have tried dissecting the WA_pages lookup generation and found that http_request does not exist.

Strangely, I get non-pageviews but no pageviews. So Analytics center works, audience works, Acquisition works, Behavior and Traffic are where it starts to break.

I have an eventype=pageview.

Is there something else I can try to get the http_request field?

0 Karma

jbjerke_splunk
Splunk Employee
Splunk Employee

Hi

I believe the problem is that the field extraction is not working for your log type. The app identifies what is a pageview (html, php etc.) vs a non-pageview (jpg, css, js). If that field is not extracted it will not work correctly.

Check using the field extractor or by manually doing a regex to get that field extracted correctly into the http_request field.

j

0 Karma

eugenek
Path Finder

Have you had any luck with this? I'm having the same issue.

0 Karma

willisiw
Explorer

Still no luck.

0 Karma

eugenek
Path Finder

I found that it was log-dependent. A different log I pulled in did have the http_request field. Since it was for a proof of concept, that worked well enough.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...