All Apps and Add-ons

Splunk App for Jenkins: Why am I unable to establish a connection between Jenkins and Splunk?

nishanth_boovat
Explorer

Hello All,

I tried using the Splunk Plugin for Jenkins, have configured Splunk on another machine, and able to hit the Splunk on a browser.

https://wiki.jenkins-ci.org/display/JENKINS/Splunk+Plugin+for+Jenkins

But connection establishment between Jenkins and Splunk is not happening, on the above link you can see step 1 on how to configure it, following that i end up by getting below error.

via port 8088:  failed: Connection refused (Connection refused)
8000: Unrecognized SSL message, plaintext connection?
8089: token: response:Unauthorized 

So not sure what's going wrong here, can someone help?

Thanks..

0 Karma
1 Solution

martin_mueller
SplunkTrust
SplunkTrust

If port 8088 isn't open, you'll first need to install the Splunk App for Jenkins: https://splunkbase.splunk.com/app/3332/
That will open a HTTP Event Collector on port 8088 to receive data from Jenkins.

View solution in original post

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

If port 8088 isn't open, you'll first need to install the Splunk App for Jenkins: https://splunkbase.splunk.com/app/3332/
That will open a HTTP Event Collector on port 8088 to receive data from Jenkins.

View solution in original post

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

Is port 8088 enabled under Global Settings on the HEC page?

nishanth_boovat
Explorer

Enabled and finally it worked 🙂 Thanks a lot martin 🙂

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

So... everything's working fine now?

0 Karma

nishanth_boovat
Explorer

No, still the same error on connection testing.

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

Mkay, next step would be to check if your splunk actually does have a HEC port open under 8088 and the token you're using on the Jenkins side is configured there - go to Settings -> Data Inputs -> HTTP Event Collector in the Splunk UI.

0 Karma

nishanth_boovat
Explorer

i was not having a token value initially so created it and added the same to jenkins, so its the same on both ends.

0 Karma

martin_mueller
SplunkTrust
SplunkTrust

Can you telnet to 8088 from the splunk host itself? Either the port's not open, or your network doesn't let it through.

0 Karma

nishanth_boovat
Explorer

/opt/splunk/etc/apps # telnet localhost 8088
Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused

I tried checking the firewall rule and flushed the rules, still the same error persist.

0 Karma

nishanth_boovat
Explorer

Hello Martin,

Thank you for the reply, i have already installed Splunk app for jenkins but its the same error that i mentioned is coming up. Tried restarting both splunk and jenkins didn't help.

port 8088: failed: Connection refused (Connection refused)

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.