All Apps and Add-ons
Highlighted

Need Help Installing/Configuring Splunk for VMWare App

Builder

I am having some trouble installing and configuring the new Splunk for VMWare App. It might just be me doing something stupid/not obvious. The docs are good, but perhaps too detailed to some extent. I'm following them along correctly, I think, but wondering if any of you who've been successful with getting it working can share your secret to success or point me to the right parts of the documentation or provide hints or tips/tricks that I can try. Anything would be greatly appreciated. Thanks.

0 Karma
Highlighted

Re: Need Help Installing/Configuring Splunk for VMWare App

Explorer

What kind of issue are you seeing?

0 Karma
Highlighted

Re: Need Help Installing/Configuring Splunk for VMWare App

Builder

Here's imo the TL;DR response to our docs:

  1. Install the DCN, make sure the firewall is off and either allow remote auth or change the default password.
  2. Install the main app
  3. Add the dcn's IP and login creds to the VC ( I'd even recommend not turning on syslog till you know you're collecting data)
  4. Add the "splunk_vmware_admin" role to your main user
  5. Hit start scheduler

Hopefully that gets you data, most often people forget the role, or they have user perm issue with the VC. If you're not getting any data in and the checkmarks are all "green" on the config page, you'll probably find a detailed reason in the hydra logs.

Highlighted

Re: Need Help Installing/Configuring Splunk for VMWare App

Explorer

Some troubleshooting information, to help you pinpoint your issues:

Highlighted

Re: Need Help Installing/Configuring Splunk for VMWare App

Path Finder

You can also take a look at the Installation Video Guide.

https://www.youtube.com/watch?v=GgJUkh0eFH4

Feedback welcome.

0 Karma