All Apps and Add-ons

NMON not finding Oracle Linux hosts

sov_gwright
New Member

The forwarder is working and sending data, but the Linux dashboard shows no hosts. I believe this has to do with us running Oracle Linux 7.6 (which is just RHEL 7.6 with Oracle's branding). Below are the outputs of osrelease and redhat-release, is there something I can do to force NMON to recognize OEL 7.6 as RHEL?

os-release

NAME="Oracle Linux Server"
VERSION="7.6"
ID="ol"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.6"
PRETTY_NAME="Oracle Linux Server 7.6"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:oracle:linux:7:6:server"
HOME_URL="https://linux.oracle.com/"
BUG_REPORT_URL="https://bugzilla.oracle.com/"

ORACLE_BUGZILLA_PRODUCT="Oracle Linux 7"
ORACLE_BUGZILLA_PRODUCT_VERSION=7.6
ORACLE_SUPPORT_PRODUCT="Oracle Linux"
ORACLE_SUPPORT_PRODUCT_VERSION=7.6

redhat-release

Red Hat Enterprise Linux Server release 7.6 (Maipo)
0 Karma

sov_gwright
New Member

Sorry yes I forgot to update - I went through everything (we do have Python installed), completely removed the nmon add-on, deleted the nmon index, and redeployed and it started working. I don't know what I did wrong the first time, but it was clearly me and not your add-on. Thanks for the help, the data we're able to analyse now using your work is exactly what we needed!

0 Karma

guilmxm
Influencer

Awesome @sov_gwright thanks.

Just so you know, there is metric store version of both the TA and the App:
https://splunkbase.splunk.com/app/3947/

I'll let you choose which comment/reply to tag as a reply.

0 Karma

guilmxm
Influencer

Hi @sov_gwright

I will verify, it must not be able to find a binary that suits the system, which you shall be able to in the sourcetype=nmon_collect.

Something you can do on your own easily is deploying the nmon binary on the server, the TA will try to use nmon binary available in the path in the last attempt.

There is a linux.tgz archive located in TA-nmon/bin/ with inside the archive an "ol" directory.

Will you keep you informed shortly.

Kind regards,

Guilhem

0 Karma

guilmxm
Influencer

Hi @sov_gwright

I replied a little bit in a rush.

Can you go through the trouble shooting guide and let me know:

https://ta-nmon.readthedocs.io/en/latest/troubleshoot.html

You might just be missing requirements, if your host don't have a Python interpreter the TA switches to Perl which has some requirements:

https://ta-nmon.readthedocs.io/en/latest/requirements.html

The content of splunkd.log (index=_internal source=*/splunkd.log host=xxx error OR warn) and sourcetype=nmon_collect will tell you the truth.
The truth is in the logs, always 😉

0 Karma

guilmxm
Influencer

Hi @sov_gwright

Any update ?

Feel free if I can help.

Kind regards,

Guilhem

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...