All Apps and Add-ons

Machine Learning Toolkit: Do you have to install the Python for Scientific Computing add-on first?

jshultz
Explorer

For the Machine Learning Toolkit, do you have to install the Python for Scientific Computing add-on first? I installed both but the showcase display is empty and no data is available.

0 Karma

leogan
Engager

I"ve solved this problem.
I used CLI command:
- first, removed both apps (for Python, I had to manually remove App folder after removing app)
- second, install them again: Python then MLToolkit

leogan
Engager

I have the same problem.
I first install ML Toolkit, then Python_for_...
ML Toolkit shows this error "You must have the Python for Scientific Computing App version 1.2 or later installed to use the Machine Learning Toolkit."
So I tried to install ML Toolkit again (with "Upgrade app. Checking this will overwrite the app if it already exists." checkbutton). Restarted Splunk. ... The same error. 😞
Reinstall Python and ML Toolkit again... The same error.

Any ideas how to manage this situation?
BTW I didn't find option to remove installed App...

0 Karma

larsonhokie
New Member

Couple of tips because I was looking for how to make this work as well. I did this from the terminal first:
1) I went ahead and stopped splunk with the $SPLUNK_HOME/bin/splunk stop command
2) I moved the apps to tmp with the mv $SPLUNK_HOME/etc/apps/Splunk_SA_Scientific_Python_windows_x86_64 /tmp
and
mv $SPLUNK_HOME/etc/apps/Splunk_ML_Toolkit /tmp commands.
3) I started the splunk instance with the $SPLUNK_HOME/bin/splunk start command
4) I went ahead and used the GUI to install both the machine learning and python apps. If you don't install python first it will warn you that you need it.
5) Restart splunk and you should be done. I was doing this on 64bit Unbuntu.

I had an issue with a bad copy of python, so deleting from splunkbase fixed my issue. Good Luck!

0 Karma

stekosan
Explorer

same issue for me

0 Karma

ChrisG
Splunk Employee
Splunk Employee

Yes, you have to install it first, see Install the Machine Learning Toolkit in the documentation. Did you do your installation in the opposite order?

aaraneta_splunk
Splunk Employee
Splunk Employee

Hi @jschultz,

Which Python for Scientific Computing did you install? The one for:
- Mac
- Windows 64-bit
- Linux 32-bit
- Linux 64-bit

I just want to make sure your post is tagged correctly. Thanks!

0 Karma

jshultz
Explorer

Linux 64-bit

0 Karma