All Apps and Add-ons

(JMXPoller) failed to initialize

johnsmithbitter
Explorer

I have recently moved from splunk 5 to 6 doing a new full rebuild to version 6. I had the JMX App running without any issues, but I now can't get it to work in version 6

I've checked the inputs.conf to my old version, the config files are the same

Java home is set....

I receive this error message below in the splunkd.log

"python /fast/splunk/etc/apps/jmx_ta/bin/jmx.py" The root config object(JMXPoller) failed to initialize, stanza : null

Anyone have any ideas?

0 Karma

Damien_Dallimor
Ultra Champion

Is your inputs.conf setup correctly ?

Is your config file that is defined in your inputs.conf stanza present in your etc/apps/jmx_ta/bin/config directory ? Or in the directory you may have specified with a custom config directory location ?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...