All Apps and Add-ons

Is Splunk Supporting Add-on for Active Directory Compatible with python 3?

Krithika
Observer

Hello,

is Splunk Supporting Add-on for Active Directory version 3.0.5 is  compatible with python 3 ?

Thanks,

Krithika

 

 

Labels (1)
0 Karma

newsplunker1
Path Finder

@Krithika No issues have been noticed when I upgraded to 9.01 four months ago. It passed the upgrade readiness app . 

0 Karma

richgalloway
SplunkTrust
SplunkTrust

I installed the app and scanned it using the Upgrade Readiness app (4.1.0).  It passed the Python3 checks.

richgalloway_0-1678208323993.png

 

---
If this reply helps you, Karma would be appreciated.

linhmai_bne
Path Finder

I just upgraded to Splunk 9.0.3 and SA-ldap 3.0.6. And I have this error

linhmai_bne_0-1678331632925.png

SA-ldap not compatible with Python 3

0 Karma

richgalloway
SplunkTrust
SplunkTrust

So the Upgrade Readiness App lied.  Sorry about that.

Also, I believe you'll find the SA_ldapsearch app is not supported by Splunk Cloud.

---
If this reply helps you, Karma would be appreciated.
0 Karma

JeffKitchens
Engager

Thanks Rick!

0 Karma

JeffKitchens
Engager

I have the same question but can find no response from the community.

 

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The Release Notes (https://docs.splunk.com/Documentation/SA-LdapSearch/3.0.0/User/ReleaseNotes) say the app supports Python 3 as of version 3.0.0.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

Using the Splunk Threat Research Team’s Latest Security Content

REGISTER HERE Tech Talk | Security Edition Did you know the Splunk Threat Research Team regularly releases ...

SplunkTrust | 2024 SplunkTrust Application Period is Open!

It's that time again, folks! That's right, the application/nomination period for the 2024 SplunkTrust is ...