All Apps and Add-ons

Internal configuration file error. Something wrong within the package or installation step. Contact your administrator for support. Detail: instance.pages.configuration.tabs[0].entity[0].label does not meet maximum length of 30

jkat54
SplunkTrust
SplunkTrust
Internal configuration file error. Something wrong within the package or installation step. Contact your administrator for support. Detail: instance.pages.configuration.tabs[0].entity[0].label does not meet maximum length of 30

I received the error above with the add-on i built with the AOB. I solved on my own, and will post the answer below.

0 Karma
1 Solution

jkat54
SplunkTrust
SplunkTrust

The problem was that one of my parameters had a name that was too long.

I originally had the following parameter:

param.service_now_incident_endpoint = <string> Service Now Incident Endpoint

I changed to something less than 30 characters long for the key name:

param.incident_endpoint = <string> Service Now Incident Endpoint

That resolved the error.

View solution in original post

0 Karma

jkat54
SplunkTrust
SplunkTrust

The problem was that one of my parameters had a name that was too long.

I originally had the following parameter:

param.service_now_incident_endpoint = <string> Service Now Incident Endpoint

I changed to something less than 30 characters long for the key name:

param.incident_endpoint = <string> Service Now Incident Endpoint

That resolved the error.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...