All Apps and Add-ons

Internal configuration file error. Something wrong within the package or installation step. Contact your administrator for support. Detail: instance.pages.configuration.tabs[0].entity[0].label does not meet maximum length of 30

jkat54
SplunkTrust
SplunkTrust
Internal configuration file error. Something wrong within the package or installation step. Contact your administrator for support. Detail: instance.pages.configuration.tabs[0].entity[0].label does not meet maximum length of 30

I received the error above with the add-on i built with the AOB. I solved on my own, and will post the answer below.

0 Karma
1 Solution

jkat54
SplunkTrust
SplunkTrust

The problem was that one of my parameters had a name that was too long.

I originally had the following parameter:

param.service_now_incident_endpoint = <string> Service Now Incident Endpoint

I changed to something less than 30 characters long for the key name:

param.incident_endpoint = <string> Service Now Incident Endpoint

That resolved the error.

View solution in original post

0 Karma

jkat54
SplunkTrust
SplunkTrust

The problem was that one of my parameters had a name that was too long.

I originally had the following parameter:

param.service_now_incident_endpoint = <string> Service Now Incident Endpoint

I changed to something less than 30 characters long for the key name:

param.incident_endpoint = <string> Service Now Incident Endpoint

That resolved the error.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...