All Apps and Add-ons

Help with Splunk DB connect Rising search

dorbi
Explorer

i have this search:

 

 

 

SELECT
C_ID,
REPLACE(REPLACE(REPLACE(REPLACE(C_XML,'"',''''), CHAR(13), ''), CHAR(10), ''),'  ','') as C_XML,
C_TENANT_ID,
C_MESSAGE_PRIORITY,
C_CREATED_DATE_TIME,
C_WAS_PROCESSED,
C_LOGICAL_ID
FROM "ElbitErrorHandlingDB"."dbo"."COR_INBOX_ENTRY" 
WHERE C_CREATED_DATE_TIME > ?
ORDER BY C_CREATED_DATE_TIME ASC

 

 

and i want to add 

 

 

and

 

 

 

clause to the where section.

for some reason it doesn't work.

i tried:

 

 

SELECT
C_ID,
REPLACE(REPLACE(REPLACE(REPLACE(C_XML,'"',''''), CHAR(13), ''), CHAR(10), ''),'  ','') as C_XML,
C_TENANT_ID,
C_MESSAGE_PRIORITY,
C_CREATED_DATE_TIME,
C_WAS_PROCESSED,
C_LOGICAL_ID
FROM "ElbitErrorHandlingDB"."dbo"."COR_INBOX_ENTRY" 
WHERE C_CREATED_DATE_TIME > ?
and C_CREATED_DATE_TIME > convert(varchar,'2022-08-31',121) 
ORDER BY C_CREATED_DATE_TIME ASC

 

 

and i tried:

 

 

SELECT
C_ID,
REPLACE(REPLACE(REPLACE(REPLACE(C_XML,'"',''''), CHAR(13), ''), CHAR(10), ''),'  ','') as C_XML,
C_TENANT_ID,
C_MESSAGE_PRIORITY,
C_CREATED_DATE_TIME,
C_WAS_PROCESSED,
C_LOGICAL_ID
FROM "ElbitErrorHandlingDB"."dbo"."COR_INBOX_ENTRY" 
WHERE C_CREATED_DATE_TIME > convert(varchar,'2022-08-31',121) 
AND C_CREATED_DATE_TIME > ?
ORDER BY C_CREATED_DATE_TIME ASC

 

 

both didn't worked.

any advice?

0 Karma
1 Solution

dorbi
Explorer

The problem was with the data itself (heavy).

Issues can be closed 

View solution in original post

0 Karma

dorbi
Explorer

The problem was with the data itself (heavy).

Issues can be closed 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...