All Apps and Add-ons

Hadoop Connect - Schedule Error

sdeepika
New Member

I successfully connected Splunk with my Hadoop cluster, I could also test using the commands specified in Splunk connect documentation successfully

Test write access to the Hadoop cluster
To test write access to your Hadoop cluster, run this command in the path where you want to export data:

$HADOOP_HOME/bin/hadoop fs -touchz hdfs://://foo.txt
$HADOOP_HOME/bin/hadoop fs -rm hdfs://://foo.txt

But when I Schedule it to send the log files I get the below error:

ERROR: Error in 'movehdfs' command: {"error": "moveFromLocal: File /CYF-TS1/WinEventLog_System/17a9a87ea0c80e26fe8f4f366a516928_1461297600_1461326400_17_1.json.gz.hdfs.COPYING could only be replicated to 0 nodes instead of minReplication (=1). There are 1 datanode(s) running and 1 node(s) are excluded in this operation.", "id": "HCERR0001", "message": "Failed to run hadoop CLI Job", "cmd": "-moveFromLocal", "options": "/opt/splunk/var/run/splunk/dispatch/1461353114.62/dump/CYF-TS1/WinEventLog:System/17a9a87ea0c80e26fe8f4f366a516928_1461297600_1461326400_17_1.json.gz,hdfs://172.16.30.140:8020/CYF-TS1/WinEventLog_System/17a9a87ea0c80e26fe8f4f366a516928_1461297600_1461326400_17_1.json.gz.hdfs"}

Please let me know how to resolve this issue.

0 Karma

rdagan_splunk
Splunk Employee
Splunk Employee

Have you try to run the same command as Hadoop connect?
It looks like Hadoop Connect is trying to run the command hadoop fs -moveFromLocal

Have you seen this video to install the App: http://www.splunk.com/view/SP-CAAAHBZ
Note:
Do not include hdfs:// in the HDFS URI
Do not include bin/hadoop in the Hadoop Home
Do not include bin/java in the Java Home

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...