All Apps and Add-ons

Error installing Splunk IT Essentials Work- Anyone encountered this error and managed to install IT Essentials Work?

joshiro
Communicator

We are currently using Splunk Enterprise OnPrem 9.0.0 and when we try to install IT Essentials Work (https://splunkbase.splunk.com/app/5403/) it raises the following error: "Invalid app contents: archive contains more than one immediate subdirectory: and DA-ITSI-DATABASE".

Anyone encountered this error and managed to install IT Essentials Work?

Labels (1)
Tags (2)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

It sounds like you're trying to install ITEW using the GUI.  You should use the CLI, instead.  See https://docs.splunk.com/Documentation/ITEWork/4.13.1/Install/Install

---
If this reply helps you, Karma would be appreciated.

View solution in original post

CSmoke
Path Finder

I received the same error. On Windows, I unzipped with 7-zip, copied the file to \etc\apps, restarted Splunk. App seems to work correctly.

richgalloway
SplunkTrust
SplunkTrust

It sounds like you're trying to install ITEW using the GUI.  You should use the CLI, instead.  See https://docs.splunk.com/Documentation/ITEWork/4.13.1/Install/Install

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...