All Apps and Add-ons

Error during searching

sandeepkumar23
Explorer

I see this error when trying to search the log with index="mongodb_vix":
[local-mongodb] Error while running external process, return_code=1. See search.log for more info

Here is my indexes.conf file:
[provider-family:mongodb_erp_family]
vix.mode=stream
vix.command=/usr/java/latest/bin/java
vix.command.arg.1 = -Xmx512m
vix.command.arg.2 = -classpath
vix.command.arg.3 = $SPLUNK_HOME/bin/jars/SplunkMR-s6.0-h1.0.jar : SPLUNK_HOME/etc/apps/MongoDBApp/bin/hunk_mongodb_app.jar:$SPLUNK_HOME/etc/apps/MongoDBApp/bin/lib/

vix.command.arg.4 = com.splunk.erp.mongodb.MongoDBERP
[provider:local-mongodb]
vix.family=mongodb_erp_family
vix.splunk.search.debug = 0
vix.mongodb.host =
[mongodb_vix]
vix.provider = local-mongodb
vix.mongodb.db =
vix.mongodb.collection =
vix.mongodb.field.time = timestamp
vix.mongodb.time.format = date
vix.mongodb.auth.mechanism = CR
vix.mongodb.auth.username =
vix.mongodb.auth.password = *

On the UI, I can see local-mongodb under providers, but I do not see anything under Virtual Indexes, I see only this message there:
Virtual indexes are used to connect Splunk with data received from providers, or external storage systems, such as Hadoop or Cassandra. You must have specific licenses for these providers to use this feature.

Can anyone assist please?

Tags (1)
0 Karma

sandeepkumar23
Explorer

I had same issue and resolved it by updating "jar" location in indexes.conf

Check available jars in your Splunk $SPLUNK_HOME/bin

Old config:

vix.command.arg.3 = $SPLUNK_HOME/bin/jars/SplunkMR-s6.0-h1.0.jar : SPLUNK_HOME/etc/apps/MongoDBApp/bin/hunk_mongodb_app.jar:$SPLUNK_HOME/etc/apps/MongoDBApp/bin/lib/

Splunk version 6.6.7

Updated indexes.conf to below Config:

vix.command.arg.3 = $SPLUNK_HOME/bin/jars/SplunkMR-h1.jar:$SPLUNK_HOME/etc/apps/MongoDBApp/bin/hunk_mongodb_app.jar:$SPLUNK_HOME/etc/apps/MongoDBApp/bin/lib/*

rdagan_splunk
Splunk Employee
Splunk Employee

Hi. What is the error you see in the search.log file?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...