All Apps and Add-ons

Display same JSChart in pages inside LinkSwitcher module after use Multiplexer

cycheng
Path Finder

I am using a Multiplexer module inside a LinkSwitcher module. There are "Page 1" and "Page 2" link element inside the LinkSwitcher module. I use Multiplexer module in "Page 2" to display multiple JSChart based on field "feature". Indeed, it will display the correct charts in "Page 2". But when I click on "Page 1", the same charts will appear also. What can I do so that the charts will only show in "Page 2"?

  <module name="LinkSwitcher" layoutPanel="panel_row1_col1">
    <param name="mode">independent</param>
    <param name="label"> </param>

    <module name="Search" group="Page 1" layoutPanel="panel_row1_col1" autoRun="True">
      <param name="search"><my_search></param>

      <module name="Pulldown">
        :

        <module name="Search" layoutPanel="panel_row1_col1">
          <param name="search"><my_search2></param>
          <module name="Pulldown">

          </module>          
        </module>
      </module>

      <module name="Search" group="Page 2" layoutPanel="panel_row1_col1" autoRun="True">
        <param name="search"><my_search></param>
        <module name="Pulldown">
          :

          <module name="Search" layoutPanel="panel_row1_col1">
            <param name="search"><my_search2></param>
            <module name="Pulldown">
              :

              <module name="Search" layoutPanel="panel_row2_col1">
                <param name="search"><my_search3></param>
                <module name="PostProcess">
                  <param name="search"><my_search4></param>
                  <module name="Pulldown">
                    :

                    <module name="PostProcess">
                      <param name="search"><my_search5></param>                                
                        <module name="JobProgressIndicator"/>
                        <module name="JSChart">
                          <param name="width">100%</param>
                          <param name="height">200px</param>
                        </module> 
                    </module>

                    <module name="Search" layoutPanel="panel_row1_col1">
                      <param name="search"><my_search6></param>

                      <module name="Multiplexer">
                        <param name="field">feature</param>
                        <module name="Search">
                          <param name="search"><my_search7></param>

                          <module name="HTML">
                            <param name="html"><![CDATA[ 
                                    <h1>Passing Rate for $feature$</h1><br>
                                    </div>
                                        ]]></param>
                          </module>

                          <module name="JobProgressIndicator"/>
                          <module name="JSChart">
                            <param name="width">100%</param>
                            <param name="height">200px</param>
                          </module>
                        </module>
                      </module>
                    </module>  
                  </module>
                </module>
              </module>
            </module>
          </module>
        </module>
      </module>
    </module>
  </module>

sideview
SplunkTrust
SplunkTrust

It looks like this is a timing issue - can you confirm that if you let all the searches under the Multiplexer run to completion, and then you change to page 1, that the bug goes away - ie that the charts then remain hidden until you switch back to "page 2"? I think what happens is that the LinkSwitcher click happens while the searches and charts are still in mid-run and/or mid-render even.

Either way it definitely sounds like a bug - I was able to reproduce the timing issue as described, I'm just looking for a little more information to confirm that what you're seeing and what I'm able to reproduce is actually the same thing before I go about fixing it. Thanks.

0 Karma

cycheng
Path Finder

Yes,you are correct. The bug goes away if I wait all the searches completed in "Page 2" and then I switch to "Page 1". The "Page 1" is my default view and each time I refresh the view, it will show the charts in "Page 1". Is it any module I can use to prevent it runs the searches in "Page 2"? Or perhaps I shouldn't use the LinkSwithcer module? Thanks.

0 Karma
Get Updates on the Splunk Community!

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Avoid Certificate Expiry Issues in Splunk Enterprise with Certificate Assist

This blog post is part 2 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Using Machine Learning for Hunting Security Threats

REGISTER NOW Seeing the exponential hike in global cyber threat spectrum, organizations are now striving more ...