All Apps and Add-ons

Debugging missing logs from Jenkins Plugin for splunk


We're using the Jenkins Plugin for Splunk , and I'm having trouble tracing an issue down. One of the default configurations for the app is to send all files in the workspace with a *.log format to Splunk w/ an HEC configuration. We've had this working fine for about a year now, and continues to work in most cases, but one in particular is giving me some trouble. There's one line in the console output in particular which confuses me -
sent [C:\Jenkins-data\Test_Report\workspace\Testing.log] to splunk in 1 event
I've confirmed that it does not live in Splunk, the host is still a valid forwarder/client (other logs are sending) I can't find any issues in
index=_internal sourcetype=splunkd over the time frame of the job, and otherwise I'm not sure where to debug from there. I've also tried converting the file format to json in case it only accepted that data type. Any thoughts/next steps? Much appreciated.


Hello @aberkow,
Not sure if I understood your question, but have you check if this particular build is properly configured under
"Send Files to Splunk" configuration? What is the size of this log? Have you tried to increase the Max file size?

0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!