All Apps and Add-ons

DB Connect Perms?

tmarlette
Motivator

I just installed DB Connect on my system, and it is working fine when I am logged in as an administrator, but when I log in as a regular user Splunk throws an error:

error message that I get:
PARSER: Applying intentions failed Unknown search command 'dbinfo'.

I am assuming that this is a permissions based issue, and I was just looking for what Splunk permission would allow users to use DB Connect?

Thank You!

Tags (1)
0 Karma
1 Solution

ziegfried
Influencer

You have to grant access to the dbinfo command (and other DB Connect commands) to the roles that should be able to use it.

Go to

  1. Splunk Manager
  2. Advanced search
  3. Search commands
  4. Select app context "Splunk DB Connect" and check "Show only objects created in this app context"
  5. Click on the "Permissions" link for the entries you want to change

Before DB Connect 1.0.9, some additional steps are necessary: http://docs.splunk.com/Documentation/DBX/1.0.8/DeployDBX/Securityandaccesscontrols

View solution in original post

ziegfried
Influencer

You have to grant access to the dbinfo command (and other DB Connect commands) to the roles that should be able to use it.

Go to

  1. Splunk Manager
  2. Advanced search
  3. Search commands
  4. Select app context "Splunk DB Connect" and check "Show only objects created in this app context"
  5. Click on the "Permissions" link for the entries you want to change

Before DB Connect 1.0.9, some additional steps are necessary: http://docs.splunk.com/Documentation/DBX/1.0.8/DeployDBX/Securityandaccesscontrols

tmarlette
Motivator

I was using DB Connect 1.0.8, so I just upgraded and followed your instructions here. Worked perfectly. Thank you!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Analytics Workspace removal in Splunk 10.6

In Splunk Cloud Platform and Splunk Enterprise 10.6, Analytics Workspace is removed from product and no longer ...

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...