All Apps and Add-ons

Custom Cluster Map & Geo Heatmap Custom Visualization: How to make these map apps work on Splunk?

DavidLago
New Member

I have installed some apps, including Custom Cluster Map Visualization and Geo Heatmap Custom Visualization, but there is little or no information about them in the internet, also the app do not provide a help file or anything like it.

I'm stuck, I have no idea how to make that work.

So far I've listed the cities I want to be shown in red on the map (in case a specific value crosses a threshold), I have all the Lat and Long for each of them, but nothing that I test show any results. For example:

earliest=-15m object="Processor" counter="% Processor Time" sourcetype=CPU | where Value>90 | table host Value | geostats latfield=25.204849 longfield=55.270783 avg(count)

How do I get started here?

0 Karma

ziegfried
Influencer

geostats expects field names for latfield/longfield instead of values. Otherwise your search looks reasonable. Try this instead:

 earliest=-15m object="Processor" counter="% Processor Time" sourcetype=CPU | where Value>90 | table host Value | eval lat=25.204849 | eval long=55.270783 | geostats latfield=lat longfield=long avg(count)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...