All Apps and Add-ons

Creating a table from diff source

marinewcreater
Explorer

HI Team,

I would like to create a table in a dashboard from two difference results.

Eg: Blue stack results and Green stack results has to display on a same table like below.

Green /t Blue

Service Call_count Service Call_count

0 Karma
1 Solution

marinewcreater
Explorer

index = avb source = "blue | stats count by Service, Call_count
index = avb source = "Green | stats count by Service, Call_count

Is it possible to display both results in same table, as Header Green / Blue and next line header as Service / Call_count

0 Karma

dindu
Contributor

Hi,
Please check whether the below snippet is what you are looking for.

  index=avb source="blue" 
 |eval Blue_Green="Blue"
 |stats count as "Service_Call Count" by Service, Call_count ,Blue_Green
 |append [ search index=avb source="Green"
 |eval Blue_Green="Green"
 |stats count as "Service_Call Count" by Service, Call_count,Blue_Green]
  |fields - Service,Call_count
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...