All Apps and Add-ons

Configuring Snort

w0lverineNOP
Path Finder

I am trying to configure splunk to read my alerts files from snort but the documentation is vague in my understanding or I do not understand what they are asking.

From Splunk for snort app:
1.What do you mean by "enable appropriate inputs via inputs.conf"? The file is basically empty in /opt/splunk/etc/system/local/input.conf

Thanks alot!

Tags (1)
0 Karma
1 Solution

renjith_nair
SplunkTrust
SplunkTrust

The default location of inputs.conf in splunk is under /opt/splunk/etc/system/default. However, if user wants to make any changes to this file, its better to add a new file inputs.conf under /opt/splunk/etc/system/local and make the necessary changes or add necessary stanzas under this. The configuration under local will override the values in default.

If you want to forward some logs from your snort , configure the log file in the monitor stanza in inputs.conf something like below

[monitor://<path to your log file>]
disabled = false
sourcetype = <sourcetype fr your logs> (eg:snort_alert_full)
source = snort
index = <your index name in splunk>

Refer http://docs.splunk.com/Documentation/Splunk/6.3.1/Data/Monitorfilesanddirectorieswithinputs.conf for more information

View solution in original post

renjith_nair
SplunkTrust
SplunkTrust

The default location of inputs.conf in splunk is under /opt/splunk/etc/system/default. However, if user wants to make any changes to this file, its better to add a new file inputs.conf under /opt/splunk/etc/system/local and make the necessary changes or add necessary stanzas under this. The configuration under local will override the values in default.

If you want to forward some logs from your snort , configure the log file in the monitor stanza in inputs.conf something like below

[monitor://<path to your log file>]
disabled = false
sourcetype = <sourcetype fr your logs> (eg:snort_alert_full)
source = snort
index = <your index name in splunk>

Refer http://docs.splunk.com/Documentation/Splunk/6.3.1/Data/Monitorfilesanddirectorieswithinputs.conf for more information

View solution in original post