All Apps and Add-ons

Cisco ESA Combine logs

mkarimi17
Path Finder

My ironport logs are not getting parsed incorrectly into the Email data model. The logs all come individually and as seperate events for each MID. I installed the add-on and that created some of the needed CIM and fields, including internal_message_id. The search

index=email sourcetype="cisco:esa:textmail" | transaction internal_message_id 

Give me the email as one unit. When I run:

| tstats values(All_Email.src_user) values(All_Email.action) values(All_Email.recipient) values(All_Email.src) FROM datamodel=Email WHERE sourcetype="cisco:esa:textmail" BY All_Email.subject

I get the subject, however the other fields are "unknown".

I created a Transaction Dataset to combine the fields on internal_message_id but that didn't fix anything.

mikaelbje
Motivator

If you download my companion add-on it will take care of this for you and collect the fields into a separate summary index every hour.

See https://github.com/inspired/TA-cisco-esa-extras

You will still need the Splunk Add-on for Cisco ESA

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...