All Apps and Add-ons
Highlighted

Can not communicate with task server, please check your settings.

Explorer

Hi Team,

Can some on help to solve this issue, I have installed DB connect on Splunk enterprise after launch the apps I am getting following error message

Error: Can not communicate with task server, please check your settings.

JDK 8 is installed

I have followed the following article but does not help me

https://answers.splunk.com/answers/507416/splunk-db-connect-how-to-resolve-can-not-communica.html?ut...

Highlighted

Re: Can not communicate with task server, please check your settings.

Path Finder

Seems it is still not able to find java. Go to configurations/settings can put in the path to your java.

0 Karma
Highlighted

Re: Can not communicate with task server, please check your settings.

Contributor

thank you, but how can this be performed when I am re-directed to the URL?

http://192.168.1.71:8000/en-US/app/splunk_app_db_connect/ftr#/welcome?_k=hkfaxp

which then hangs. the original (title) message "Can not communicate with task server, please check your settings." - I can fully see only with a Print-screen to Bmp

regards
Altin

ps. and I did all on the URL given above to no result

0 Karma
Highlighted

Re: Can not communicate with task server, please check your settings.

Contributor

I did the change to 1025 - it didn't work. and I turned it again to 9998 - same result.
In both cases, when I start Splunk I have the following output:

[splunk@srvsplunk bin]$ ./splunk start

Splunk> CSI: Logfiles.

Checking prerequisites...
    Checking http port [8000]: open
    Checking mgmt port [8089]: open
    Checking appserver port [127.0.0.1:8065]: open
    Checking kvstore port [8191]: open
    Checking configuration...  Done.
    Checking critical directories...    Done
    Checking indexes...
        Validated: _audit _internal _introspection _telemetry _thefishbucket history main omega_ca_nt omega_ds omega_ds_idx_01 omega_nt_ora summary
    Done
    Checking filesystem compatibility...  Done
    Checking conf files for problems...
        Invalid key in stanza [dbx_java_installation_health_check] in /opt/splunk/etc/apps/splunk_app_db_connect/default/checklist.conf, line 17: doc_title  (value:  DB Connect JVM installation).
        Invalid key in stanza [dbx_driver_installation_health_check] in /opt/splunk/etc/apps/splunk_app_db_connect/default/checklist.conf, line 41: doc_title  (value:  DB Connect JDBC Driver installation).
        Invalid key in stanza [dbx_connections_configuration_health_check] in /opt/splunk/etc/apps/splunk_app_db_connect/default/checklist.conf, line 69: doc_title  (value:  DB Connect connection configuration,DB Connect identity configuration).
        Invalid key in stanza [dbx_data_lab_configuration_health_check] in /opt/splunk/etc/apps/splunk_app_db_connect/default/checklist.conf, line 85: doc_title  (value:  DB Connect input configuration,DB Connect output configuration,DB Connect lookup configuration).
        Invalid key in stanza [dbx_java_server_configuration_health_check] in /opt/splunk/etc/apps/splunk_app_db_connect/default/checklist.conf, line 98: doc_title  (value:  DB Connect Java Server configuration).
        Your indexes and inputs configurations are not internally consistent. For more information, run 'splunk btool check --debug'
    Done
    Checking default conf files for edits...
    Validating installed files against hashes from '/opt/splunk/splunk-6.5.2-67571ef4b87d-linux-2.6-x86_64-manifest'
    All installed files intact.
    Done
All preliminary checks passed.

Starting splunk server daemon (splunkd)...  
Done
 [  OK  ]

Waiting for web server at http://127.0.0.1:8000 to be available........ Done


If you get stuck, we're here to help.  
Look for answers here: http://docs.splunk.com

The Splunk web interface is at http://srvsplunk:8000

the very strange thing on the above - is that the startup problems DO NOT appear with the 9998 port as an original setting after the DB Connect App Install, but they DO appear even when the port is set again to 9998 (after trying 1025).

regards
Altin

0 Karma
Highlighted

Re: Can not communicate with task server, please check your settings.

Explorer
  1. Remove splunkappdb_connect folder from $Splunk Home\etc\apps
  2. Download DB Connect 3.1.3 from splunk base
  3. Install DB Connect (by choosing install from file)
  4. Select DB Connect All and click setup
  5. Under Settings -> General -> Task Server Port remove 9998 and add 1025
  6. Click Save
  7. The task server restarts
  8. Again Change Task Server Port to 9998 and click save
  9. The task server restarts

That's all folks!!!

Highlighted

Re: Can not communicate with task server, please check your settings.

Engager

I have the same problem. I can see that the task Server is properly responding at:

http://127.0.0.1:1025/api/connections

Also

netstat -a -b

shows me, that the TaskServer is up and listening to the port. Maybe this might be helpful.

The splunkd.log is showing the following output after restarting Splunk:

ERROR ExecProcessor - message from
""C:\Program Files\Splunk\etc\apps\splunkappdbconnect\windowsx86_64\bin\server.exe""
com.splunk.modularinput.Event.writeTo(Event.java:65)\com.splunk.modularinput.EventWriter.writeEvent(EventWriter.java:134)\com.splunk.dbx.server.bootstrap.TaskServerStart.streamEvents(TaskServerStart.java:77)\com.splunk.modularinput.Script.run(Script.java:66)\com.splunk.modularinput.Script.run(Script.java:44)\com.splunk.dbx.server.bootstrap.TaskServerStart.main(TaskServerStart.java:150)\

Which is not really helpful for me.

0 Karma
Highlighted

Re: Can not communicate with task server, please check your settings.

Contributor

Hi All,

I have gone though all the answers and done all required changes in config but nothing will happend.
Finally, I use below steps to reslove this issue.

  1. Backup your files, if exist, ex: db_input.conf and drivers
  2. Stop splunk. Remove db_connect app from app folder.
  3. Restart Splunk.
  4. Upgrade your splunk with just new version.
  5. install > db connect app

check your db it will be okay now.

Happy Splunking !..

0 Karma
Highlighted

Re: Can not communicate with task server, please check your settings.

Loves-to-Learn

DBConnect 3.3.1 Initial Setup Encountering "cannot communicate with task server" & python script error DBConnect has this issue  our environment when a user’s setting for Time Zone is set to anything other than "–Default System Timezone-". 

0 Karma