All Apps and Add-ons

AppLocker Monitoring

wdeoliveira_spl
Splunk Employee
Splunk Employee

Hello there,

I am trying to help logs from a aplication called AppLocker running on Windows.

The logs of this application can only be viewed at the detailed tab of the event view on xml format.

Is there any specific method or tweak to set up to collect and parse data from the detailed view?

Thanks-

Wellington

ryanoconnor
Builder

Hello Wellington,

We just went through getting some AppLocker logs into Splunk today. We deployed the following paths to our inputs.conf on our Windows Servers.

[WinEventLog://Microsoft-Windows-AppLocker/EXE and DLL]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/MSI and Script]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/Packaged app-Deployment]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/Packaged app-Execution]
disabled = 0

So far we are using this in audit mode. A simple useful search we created was

source=AppLocker index=main EventCode=8003 OR EventCode=8006 | rex field=Message "(?.*)was allowed to run but would have been prevented from running if the AppLocker policy were enforced." | table _time blocked_app User host

This created a table of time, application that would have been blocked, user, and host.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...