All Apps and Add-ons

AppLocker Monitoring

wdeoliveira_spl
Splunk Employee
Splunk Employee

Hello there,

I am trying to help logs from a aplication called AppLocker running on Windows.

The logs of this application can only be viewed at the detailed tab of the event view on xml format.

Is there any specific method or tweak to set up to collect and parse data from the detailed view?

Thanks-

Wellington

ryanoconnor
Builder

Hello Wellington,

We just went through getting some AppLocker logs into Splunk today. We deployed the following paths to our inputs.conf on our Windows Servers.

[WinEventLog://Microsoft-Windows-AppLocker/EXE and DLL]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/MSI and Script]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/Packaged app-Deployment]
disabled = 0

[WinEventLog://Microsoft-Windows-AppLocker/Packaged app-Execution]
disabled = 0

So far we are using this in audit mode. A simple useful search we created was

source=AppLocker index=main EventCode=8003 OR EventCode=8006 | rex field=Message "(?.*)was allowed to run but would have been prevented from running if the AppLocker policy were enforced." | table _time blocked_app User host

This created a table of time, application that would have been blocked, user, and host.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agentic SOC Triage: Investigating Splunk ES Notables with MCP Server and a Local LLM

The Problem: Too Many Alerts, Too Little Context Security operations teams running Splunk Enterprise Security ...

All Work and No Play? Not at .conf26! Unwind at These Evening Events

Between hands-on technical sessions, keynote reveals, and diving into live architectures, .conf26 is packed ...

Join the Hackathon at .conf26 and build a No-Code AI agent

Join us for the AI Agent Buildathon, an in-person, three-hour hands-on Hackathon where you’ll use Splunk Agent ...