All Apps and Add-ons

[8.0.6] REST API call fails with error after upgrade.

Splunk Employee
Splunk Employee

After upgrade to 8.0.6 the search with "| REST " is failing when it's sent to the older versions but it is successful for the same version instances.

In GUI, " | REST splunk_server=olderversion /services/server/info " fails with the error below;

WARN: [olderversion] Unexpected status for to fetch REST endpoint uri=https://127.0.0.1:8089/services/server/info?count=0&strict=false from server=https://127.0.0.1:8089 - Bad Request

 

Labels (2)
1 Solution

Splunk Employee
Splunk Employee


It's a compatibility issue for  the command REST with an argument "strict" - this will break the search between the version 8.0.5/8.0.6 and older versions.

* The scope of impact, any search with "|REST " from 8.0.6 (or 8.0.5 ) to the older versions will fail - the version 8.0.6 always add "strict" argument which is not understood by the old versions and rejected.

----<Excerpts>---
curl -k https://splunk_ver732:8089/services/server/info?count=0\&strict=false -u admin
Enter host password for user 'admin':
<?xml version="1.0" encoding="UTF-8"?>
<response>
<messages>
<msg type="ERROR">Argument "strict" is not supported by this handler.</msg>
</messages>
</response>
------------------
The command above will be successful without "strict=false" for the older versions.

https://docs.splunk.com/Documentation/Splunk/latest/SearchReference/Rest
The fix is targetted to be included in 8.0.7 for late Oct or early Nov 2020 which is subject to change.

 

 


1925814

View solution in original post

Splunk Employee
Splunk Employee


It's a compatibility issue for  the command REST with an argument "strict" - this will break the search between the version 8.0.5/8.0.6 and older versions.

* The scope of impact, any search with "|REST " from 8.0.6 (or 8.0.5 ) to the older versions will fail - the version 8.0.6 always add "strict" argument which is not understood by the old versions and rejected.

----<Excerpts>---
curl -k https://splunk_ver732:8089/services/server/info?count=0\&strict=false -u admin
Enter host password for user 'admin':
<?xml version="1.0" encoding="UTF-8"?>
<response>
<messages>
<msg type="ERROR">Argument "strict" is not supported by this handler.</msg>
</messages>
</response>
------------------
The command above will be successful without "strict=false" for the older versions.

https://docs.splunk.com/Documentation/Splunk/latest/SearchReference/Rest
The fix is targetted to be included in 8.0.7 for late Oct or early Nov 2020 which is subject to change.

 

 


1925814

View solution in original post