All Apps and Add-ons

500 Internal Server Error - 'str' object has no attribute 'os_startIndex'

gnazer
Engager

Hello. I am testing Splunk version 4.3, build 115073 and I have the next error when I want to go to search App

500 Internal Server Error

Return to Splunk home page
AttributeError: 'str' object has no attribute 'os_startIndex'

This page was linked to from http://127.0.0.1:8000/en-US/app/launcher/home.

You are using 127.0.0.1:8000, which is connected to splunkd @115073 at https://127.0.0.1:8089 on Tue Jan 10 13:13:23 2012.

Tags (1)
1 Solution

araitz
Splunk Employee
Splunk Employee

Here is a workaround for the issue:

  • From Splunk Web, go to Manager > Your Account
  • In the Time zone setting, change the "default System Timezone" to a specific timezone
  • Save the change. No restart is needed and the error should go away

We hope to have this fixed in an upcoming maintenance release.

View solution in original post

mietmesplunk
New Member

I've got the same error "500 Internal Server Error .. AttributeError..." after installing the WindowsApp.
At first, after accessing to the WindowsApp the error was shown.
After reboot i can't acces to splunk (same errer)

Renaming the "savedsearches.conf" brought no success.

(Windows 7, 64bit, Splunk 4.3)

0 Karma

mietmesplunk
New Member

I've renamed the "savedsearches.conf" in "Splunk/etc/apps/search/local" (as you wrote above).
And I've rebootet the system.
But without success.

Now i've done the following:

renamed the folder of the app "windows" to "windows-1"

After restart, i had access to the splunk webinterface and splunk seems working well. Of course, the app "windows" is not working.

Do you have any idea, how to get the windows app working?

thanks!

0 Karma

FRoth
Contributor

Which "savedsearches.conf" did you rename (which directory)? Did you restart the service?

0 Karma

araitz
Splunk Employee
Splunk Employee

Please see my answer below for a workaround.

0 Karma

araitz
Splunk Employee
Splunk Employee

Here is a workaround for the issue:

  • From Splunk Web, go to Manager > Your Account
  • In the Time zone setting, change the "default System Timezone" to a specific timezone
  • Save the change. No restart is needed and the error should go away

We hope to have this fixed in an upcoming maintenance release.

mietmesplunk
New Member

This is not possible, when you have switched (downgraded) the licence to the coummunity-version, because the Menu "Your Account" is only available in the enterprise version

0 Karma

FRoth
Contributor

He uses a Windows OS. Saved Searches with cron scheduler settings causes this error. See my workaround below.

0 Karma

FRoth
Contributor

Workaround:

Rename savedsearches.conf in Splunk\etc\apps\search\local to savedsearches.conf.old
and restart Splunk.

Error Message still appears in the red top bar saying "'str' object has no attribute 'os_startIndex'" but you can access the search app at least.

FRoth
Contributor

I also noticed that the SAVED SEARCHES did not show correctly in my dashboards. I used "stacked" columns but the graphs did not show up "stacked".

I figured out that I had generate a viewstate for every saved search. I saved a new search and copied the veiwstate for that new and correct chart several times in the file viewstates.conf.

An entry looks like this:

[charting:gvto8fi9]
ChartTypeFormatter_0_7_0.default = column
...
StackModeFormatter_0_10_0.default = stacked
...

The id after "charting:" is the reference to the actual saved search and had to be adjusted in every block.

0 Karma

FRoth
Contributor

IMPORTANT: Every saved search containing a line to schedule the search causes the error. So it is recommended to remove the lines like

"cron_schedule = 0 * * * *" and "enableSched = 1"

0 Karma

FRoth
Contributor

These are the entries in the web_service.log

2012-01-19 10:58:49,927 ERROR   [4f17e959e732440f0] messages:124 - 'str' object has no attribute 'os_startIndex'
Traceback (most recent call last):
  File "D:\Splunk\Python-2.7\Lib\site-packages\splunk\appserver\mrsparkle\controllers\messages.py", line 81, in index
    entries = splunk.entity.getEntities(uri)
  File "D:\Splunk\Python-2.7\Lib\site-packages\splunk\entity.py", line 159, in getEntities
    offset = int(atomFeed.os_startIndex or -1)
AttributeError: 'str' object has no attribute 'os_startIndex'
0 Karma

FRoth
Contributor

Problem resides in entity.py and has to do with the used "uri" but I cant figure out how to enable debugging

0 Karma

FRoth
Contributor

Same problem here.

Windows 2008 R2 Server 64bit.
Upgrade from 4.2.4 to 4.3.

Has anyone resolved this issue somehow?

0 Karma

FRoth
Contributor

Has anyone tried to downgrade again?

0 Karma

tortuganetworks
New Member

Same Problem after upgrading from 4.2 to 4.3 on a Win2008 R2 machine when opening the search app.

0 Karma

Livia
Engager

Same Problem with Splunk 4.3 on a Win7 64-bit machine
when trying to configurate the "Windows" app.

0 Karma

lguinn2
Legend

What OS are you using?

0 Karma

andrzejwasilews
Explorer

Me too, WinXP 32-bit after test upgrade:

500 Internal Server Error

Return to Splunk home page

AttributeError: 'str' object has no attribute 'os_startIndex'
This page was linked to from https://logsrv:8000/en-US/app/search/dashboard_live.

0 Karma

booraczeq
New Member

I have similar error, displayed as red warning at the top of the screen

-'str' object has no attribute 'os_startIndex'-

ver 4.3, build 115073, WinXP 32-bit

0 Karma
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...