Alerting

udp://514 input exclusion

joeybroesky
Path Finder

We have logs coming in udp port 514 and want to exclude indexing events with the field "action" equaling "accept". We have tried inserting the following into the inputs.conf but does not work.

blacklist = action = "accept"

Please assist.

Labels (1)
Tags (2)
0 Karma
1 Solution

venkatasri
SplunkTrust
SplunkTrust

Hi @joeybroesky 

There seems no blacklist setting exist as per inputs conf - inputs.conf - Splunk Documentation

You can send the events to nullQueue to avoid indexing apply the following conf on HF/indexer. 

#props.conf
[your_udp_sourcetype/source::<source>/host::<hostname>]
TRANSFORMS-null= setnull
 
#transforms.conf
[setnull]
REGEX = action\s+=\s+\"accept\"
DEST_KEY = queue
FORMAT = nullQueue

 ----

An upvote would be appreciated and accept solution if it helps!

 

View solution in original post

venkatasri
SplunkTrust
SplunkTrust

Hi @joeybroesky 

There seems no blacklist setting exist as per inputs conf - inputs.conf - Splunk Documentation

You can send the events to nullQueue to avoid indexing apply the following conf on HF/indexer. 

#props.conf
[your_udp_sourcetype/source::<source>/host::<hostname>]
TRANSFORMS-null= setnull
 
#transforms.conf
[setnull]
REGEX = action\s+=\s+\"accept\"
DEST_KEY = queue
FORMAT = nullQueue

 ----

An upvote would be appreciated and accept solution if it helps!

 

joeybroesky
Path Finder

Thanks for your help! This did exactly what I was looking for.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...